想要装个 ionCube 真心好难

业余从事汉化工作 5 个月的 LeafletMapsMarker Pro 专业版快要面世了,如今已进入了 beta3 测试阶段。软件作者——德国小哥 Robert Harm 为了保证不被黑客破解,希望用户在自己服务器安装 ionCube 的决定还是让我从头凉到了尾……哎,虽然 ionCube 已经是行内公认的安全标准,但德国小哥你不知道老衲如今还是在原始的共享服务器阶段么?老衲木有化缘钱买 VPS 也木有精力倒腾 Linux 服务器啊!除非我找到神龙见首不见尾的系统管理员帮我折腾这事儿。目前还没联系上,因此今天早上锻炼归来就又开始折腾,希望在不骚扰系统管理员的前提下安装 ionCube,折腾半天的结果依然是——

ionCube
ionCube

看来要重启 Apache 服务器神马的才行啊?

ERRORS
The ionCube Loader must be the first Zend extension listed in the configuration file, /usr/local/etc/php5/cgi/php.ini.
The necessary zend_extension line could not be found in the configuration.
SYSTEM INFORMATION
Wizard version: 2.36
PHP uname: Linux jstel.bloghost.cn 2.6.18-274.17.1.el5 #1 SMP Tue Jan 10 17:25:58 EST 2012 x86_64
Machine architecture: x86-64
Word size: 64
Operating system: Linux 2.6.18
Security enhancements:
PHP version: 5.2.17
Is CLI?: No
Is CGI?: Yes
Is thread-safe?:
Web server: Apache/2
Server type: SHARED
PHP ini file: /usr/local/etc/php5/cgi/php.ini
Ini file found: INI FILE READABLE
PHPRC: /usr/local/etc/php5/cgi/
Loader path: LOADER PATH NOT FOUND
Hosting provider: bloghost
Provider URL:
Wizard script path: http://wp-content/plugins/leaflet-maps-marker/inc/loader-wizard.php?stype=s

共有 4 条评论

  1. Unknown Unknown Unknown Unknown

    汉化版本,不是在主服务器上提供个文件就可以?你是不是要提供全部的镜像

    1. Unknown Unknown Unknown Unknown

      @Bigman 主服务器没部署 ionCube……跟网管讨论后他们也没见动静。自定义的 inoCube 要用到自定义的 php.ini,主服务器不允许识别自己定义的 php.ini……Anyway,好消息是,软件作者也意识到了这点,昨天跟他来回几封邮件,而且还有更多的用户也给他发信说此事,今天他已经决定用加密代码(code obfuscation)来替代 ionCube 了。虽然加密代码也不保险,风险比 ionCube 大了,但总比超过半数的用户用不了专业版来得强。

发表评论

电子邮件地址不会被公开。 必填项已用*标注