看到新闻,新版 WordPress 5.2 将在 4 月末上线,要求 PHP 版本最低 5.6.20,而目前虚拟主机是 5.2。据悉,年底前 WP 将要求 PHP 版本最低至 7.2。

Minimum PHP Version Update

Important reminder: as of WordPress 5.2 beta 2, the minimum PHP version that WordPress will require is 5.6.20. If you’re running an older version of PHP, we highly recommend updating it now, before WordPress 5.2 is officially released.

...

5.6 now, but soon 7+

This is the first increase in PHP required version for WordPress since 2010, but may not be the only increase in 2019. The WordPress core team will monitor the adoption of the most recent versions of PHP with an eye towards making PHP 7+ the minimum version towards the end of the year.

看完后第一反应是备份了全站…… 😐

发信给服务商,1 分钟就有客服小姐回复说需要切换服务器。切就切吧,反正备份了。

5 分钟过后,观测到后台已升级到了 7.2。

于是将站点备份包通过云主机管理面板上传到 html 目录下,把数据库备份通过管理面板的数据库管理上传到相应数据库,管理域名解析,增加子域名,重设 Let's Encrypt,再强制刷新几次,就大功告成了。不超过半小时。

升级带来的最大好处是某些需要高版本 PHP 的主题也可以用了!