Go to http://ipw3945.sourceforge.net/, then download http://prdownloads.sourceforge.net/ipw3945/ipw3945-1.1.3.tgz?download.

Copy the firmware files to /lib/firmware/ on your system.

Reboot the system to initialize. Problem: When make the ipw3945 files, it prompts error messages as:

[root@Jack ipw3945-1.1.3]# make
ERROR: A compatible subsystem was not found in the following path[s]:/lib/modules/2.6.17-1.2187_FC5smp /lib/modules/2.6.17-1.2187_FC5smp/build

You need to install the ieee80211 subsystem from http://ieee80211.sf.net and point this build to the location where you installed those sources, e.g.

% make IEEE80211_INC=/usr/src/ieee80211/

Or use the ‘make patch_kernel’ within the ieee80211 subsystem to patch your kernel sources. So we have to do like that.

共有 0 条评论

    发表评论

    电子邮件地址不会被公开。 必填项已用*标注