All kinds of players, see:

http://www.linuxfans.org/nuke/modules.php?name=Forums&file=printview&t=141267&start=30

Audio:

Rhythmbox: http://ftp.gnome.org/pub/GNOME/sources/rhythmbox/0.9/
xmms: http://www.linuxfans.org/nuke/modules.php?name=Site_Downloads&op=geninfo&did=1387 (They do not support mp3 anymore because of license problem)

Video:

xine: http://www.xinehq.de/index.php/release
mplayer: http://www3.mplayerhq.hu/MPlayer/releases/MPlayer-1.0rc1.tar.bz2

Before all, we have to install gcc version between 2.95 and 4.x.

[root@localhost ~]# yum install gcc

Make directory at:

[root@localhost ~]# mkdir /usr/local/lib/codecs

Download some of the codec from their sourcer at here (for me the codec is here), then copy to the above directory.

If we want to use GUI for the player, we can input:

[root@localhost MPlayer-1.0rc1]# ./configure --enable-gui

We might see a warning message:

Error: The GUI requires PNG support, please install libpng and libpng-dev packages.

Install png library and png devil so we can enable GUI. Go to:

http://www.libpng.org/pub/png/libpng.html

and then find:

http://rpm.pbone.net/index.php3/stat/3/srodzaj/2/search/libpng-1.2

Then download libpng-devel-1.2.8-2.2.1.i386.rpm package for Fedora Core 5 (that’s my system):

http://rpm.pbone.net/index.php3/stat/26/dist/47/size/183912/name/libpng-devel-1.2.8-2.2.1.i386.rpm

Install.

Bad news: we still need X11 core font subsystem to enable the GUI:

[root@localhost MPlayer-1.0rc1]# ./configure –enable-gui
Error: X11 support required for GUI compilation.

So we:

[root@localhost MPlayer-1.0rc1]# yum install x11

Still not working:

[root@localhost MPlayer-1.0rc1]# vi configure.log
============ Checking for X11 headers presence ============
Result is: no (check if the dev(el) packages are installed)
##########################################
============ Checking for X11 ============
Result is: no (check if the dev(el) packages are installed)

So we change like:

[root@localhost MPlayer-1.0rc1]# cd /usr/X11R6
[root@localhost X11R6]# mkdir lib
[root@localhost X11R6]# cd lib
[root@localhost lib]# ln -s /etc/X11/ X11

Not working again… 🙁 Google google google… Then we find this: RPM Resource libX11-devel:

http://rpmfind.net/linux/rpm2html/search.php?query=libX11-devel

Again we yum install:

[root@localhost /]# yum install libX11-devel

Not working! 😳

[root@localhost /]# cd /usr/local/lib/codecs
[root@localhost codecs]# ln -s /etc/X11/ X11

No! 🙁

[root@localhost MPlayer-1.0rc1]# rpm -q X11
package X11 is not installed

This must be the reason!

Download files from:

http://download.fedora.redhat.com/pub/fedora/linux/core/updates/5/SRPMS/libX11-1.0.0-3.FC5.0.src.rpm

http://download.fedora.redhat.com/pub/fedora/linux/core/updates/5/SRPMS/libXfont-1.0.0-3.src.rpm

Then install:

[root@localhost MPlayer-1.0rc1]# ./configure --enable-gui
[root@localhost MPlayer-1.0rc1]# make; make install

Done! Note that if we don’t use GUI, we can simply right click on the music file, then choose open with -> open with other players -> mplayer.

共有 0 条评论

    发表评论

    电子邮件地址不会被公开。 必填项已用*标注