Ubuntu 9.10 安装配置 eclipse、subclipse、m2eclipse(转)

eclispe 3.51 安装:

sudo apt-get install eclipse

整完会在应用程序中多出来一项 “编程”。

此时的 eclipse 是以自带的 jre 来运行的,后面的 maven 插件会要求 eclipse 在 jdk 里运行,而不是 jre 里,所以再安装一下 jdk:

sudo apt-get install sun-java6-jdk

这样,jdk 会安装到/usr/lib/jvm/java-6-sun

然后修改 eclipse.ini

sudo vim /usr/lib/eclipse/eclipse.ini

在-vmargs 上一行加入:

-vm

/usr/lib/jvm/java-6-sun-1.6.0.15/bin

(有回车)

同时选择一下 window->preferences->java->installed jres 增加对应目录的 jre

然后开始 Help->install new software

subclipse http://subclipse.tigris.org/update_1.2.x

安装好 subclipse。subclipse 提供了 svn 的支持。

然后同样安装 m2eclipse 插件:

m2eclipse 比较麻烦,需要依次安装的有:

emf http://download.eclipse.org/modeling/emf/updates/releases/

cdt http://download.eclipse.org/tools/cdt/releases/new

wtp http://download.eclipse.org/webtools/updates

ajdt http://download.eclipse.org/tools/ajdt/34/update

zest or GEF http://download.eclipse.org/tools/gef/updates/releases/

mylyn http://download.eclipse.org/tools/mylyn/update/e3.4

最后才是 m2eclipse:

http://m2eclipse.sonatype.org/update/

注意,在安装过程中,有些 update 的 url 里有不止一个版本的选项,注意适当选取。

共有 0 条评论

发表评论

电子邮件地址不会被公开。 必填项已用*标注